Comment spécifier la version de bundler pour bundle install

Lorsque je tente de regrouper le gemfile d'un nouveau projet, j'obtiens :

Bundler could not find compatible versions for gem "bundler":
  In Gemfile:
    bundler-audit was resolved to 0.6.0, which depends on
      bundler (~> 1.2)

    rails (~> 5.2) was resolved to 5.2.1, which depends on
      bundler (>= 1.3.0)

  Current Bundler version:
    bundler (2.0.2)
This Gemfile requires a different version of Bundler.
Perhaps you need to update Bundler by running `gem install bundler`?

Could not find gem 'bundler (~> 1.2)', which is required by gem 'rails (~>
5.2)', in any of the sources.

Par conséquent, j'ai l'exécution gem install bundler '~> 1.2'. Maintenant quand je lance le gem list bundler, j'ai ces 2 versions 2.0.2, 1.17.3 Je sais à regrouper mes gemfile avec la version 1.17.3 Cependant quand je lance le bundle _1.17.3_ install, j'obtiens : Could not find command "_1.17.3_". Ce que je fais mal ici ? Comment puis-je régler ce problème ? Est-il un moyen de spécifier directement dans mon rails de projet avec la version de bundler il faut télécharger & résoudre les dépendances ?

0
2019-09-17 17:09:13
source
0 réponses

Voir d'autres questions sur les étiquettes